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FOREWORD

The CADD/GIS Technology Center for Facilities, Infrastructure, & Environment (i.e., the Center) is responsible for the design, development and maintenance of the Spatial Data Standard for Facilities, Infrastructure, and Environment (SDSFIE), and the Facility Management Standard for Facilities, Infrastructure, and Environment (FMSFIE).  These Standards are being developed so GIS and CADD users within the CADD/GIS community can easily transfer and communicate data and information.  The FMSFIE is being designed to integrate with the SDSFIE and the A/E/C CADD Standards and will consider business processes and more detailed analysis and reporting data requirements.  The SDSFIE was called the Tri-Service Spatial Data Standards (TSSDS) prior to July 1999).  The FMSFIE was called the Tri-Service Facility Management Standards (TSFMS) prior to July 1999).  The acronyms SDS and FMS were used from July 1999 until January 2001.  The SDSFIE/FMSFIE Release 2.00 was completed in January 2001.

Authors of the technical paper included Mr Eric Sheehan, Michael Baker, Jr., Inc. and Mr Barry Schimpf, Upper 90, Inc.  Technical review was accomplished by Ms Denise Martin, CADD/GIS Technology Center.
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Background

About Relational Databases
Database Management Systems (DBMS) are used to organize tabular information for retrieval and manipulation by multiple users and application programs.  Data is normally organized into tables and attributes.  Relational Database Management Systems (RDBMS) allow for the creation of links or relationships between tables.  The RDBMSis the baseline for the SDSFIE/FMSFIE

Structured Query Language (SQL) is the American National Standards Institute (ANSI) standard relational database communication language.   The SDSFIE/FMSFIE SQL Generator provided with the CD release of version 2.0 of the SDSFIE/FMSFIE produces SQL statements that can be used to generateempty tables for various types of RDBMS listed below.

· Standard ANSI 

· Microsoft SQLServer

· Informix

· Oracle

Version 2.0 of the SDSFIE/FMSFIE introduced a separate tool for creating and maintaining Microsoft Access databases.  This SDSFIE/FMSFIE Access Builder not only performs many of the functions of the SQL Generator specifically for Microsoft Access, but also permits analysis and modification of the Access Schema, including definitions, domains and values, and expanded relationships.  The new tool is also useful in upgrading from one SDSFIE/FMSFIE Release to the next.

About Access

Microsoft Access is an interactive database management system designed for the Microsoft Windows operating system.  Access has the ability to integrate data from spreadsheets, text files, and other database formats.  The user can directly import, export, and create relationships to: Microsoft Excel version 3.0 or later, Microsoft Fox Pro version 2.x or later, Microsoft SQL Server, Borland dBASE III Plus, Borland dBASE IV, Borland dBASE version 5.0, Borland Paradox version 3.0 to 5.0, Microsoft Visual FoxPro version 3.0, Lotus 1-2-3, ASCII text and all ODBC-compliant databases. Access provides the ability to convert data or reports into HTML so the user can create interactive databases and share them across an Intranet or the World Wide Web.

Microsoft Access takes advantage of the graphical user interface power and ease of use in Windows, giving the user visual access to data and simple, direct ways to view and work with information.

Access provides query and connectivity capabilities that allow the user to find desired information regardless of format or location. With the use of SQL queries, the user can work with data stored in different database formats and network locations.  The user can easily edit SQL statements at any time and view different layouts of data.  Design tools included with Access allow the user to produce forms and reports to meet exact specifications.  One can plot data, combine different forms and reports in one document, and present reports with publication-quality style.

Microsoft Access provides integration with Microsoft Visual Basic.  Integrated Development Environment (IDE) features drag-and-drop code, color-coded syntax, a debug window, and in-place object browsing.  Visual Basic for Applications – the programming language shared across all Microsoft Office applications – provides programming, interface, and debugging tools.

Obtaining Standard Symbology

Resources for creating standardized map symbols, fonts, line styles, and color shade sets for ESRI GIS packages are available from the CADD/GIS Technology Center’s home page at http://tsc.wes.army.mil. The ArcView file to download is ArcViewSym.zip, The map symbology resource files are not required to make the spatial data files compliant with the SDSFIE/FMSFIE, but are recommended. The method for implementing the color sets will be covered in the step-by-step tutorial presented in this document.

SDSFIE Implementation

Implementation Preparation

The first step in the implementation process is to perform an inventory of spatial data files you wish to implement within SDSFIE/FMSFIE compliance. If this is to be a new dataset, create a list of the Features (the Graphic Map Elements) to be included in the database or dataset.  A simple listing in a text file or spreadsheet serves well as a method to organize the data inventory.

Next you will select the features in the SDSFIE/FMSFIE that correspond to features in your existing data set or feature list.  The SDSFIE/FMSFIE Browser tool will help you with the feature selection process.  This tool allows the user to browse compliant features by structure, feature name, key word, alias, or data source.  The following steps demonstrate how to use the SDSFIE/FMSFIE Release 2.00 Browser application to find a few different features that would be included in a utilities spatial data set.

SDSFIE/FMSFIE Toolbox

The SDSFIE/FMSFIE CD includes both the data and software that make up the SDSFIE/FMSFIE.  The software includes applications for finding, viewing, and printing information about the SDSFIE features/tables and the FMSFIE tables (Browser).  In addition, the CD includes software permitting users to custom tailor their own set of features (Filter Maker and Filter Eraser), facilitating the construction of a database schema in an SQL Database (SQL Generator), building and maintaining Microsoft Access databases (Access Builder), and simple data entry tools (Data Creator).  

The toolbox software is specifically designed around the organization and structure of the SDSFIE/FMSFIE data and is provided free of charge by the CADD/GIS Technology Center in Vicksburg, MS.  Questions and/or problems regarding the toolbox should be addressed to the Center.

SDSFIE/FMSFIE Browser (Finding Features)

To open and configure the browser
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Figure 1 - The Browser Master Menu

1. From the Windows Start Menu choose SDS FMS Browser

2. From the <Configure> menu choose <Connect>.
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Figure 2 - The Connection Screen

3. In the Connection Screen (Figure 2), Verify and/or change the location of the data connection files and choose <Connect, Test and Save>.

NOTE:  These connections are automatically repeated each time the Browser is started.
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Figure 3 - Setting Options

4. From the <Configure> menu choose <Options>.

5. From the GIS Software tab (Figure 3) choose ArcView/ArcInfo, then choose <Apply> and/or <Ok>.

6. Other configuration options, use the Special Features tab, and then choose <Ok>.

Browsing Techniques

Browse by Structure – Navigate through the SDSFIE/FMSFIE using its structure.

Next you will take a look at all the Entity Classes in the Utilities entity set.

1. From the <Browse> menu choose <By Structure>.
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Figure 4 - Entity Set Window

2. Choose <Entity Sets> to display the Entity Set Window (Figure 4), then double-click on utilities from the Entity Set window to display the Entity Class Window (Note:  Double-clicking on any white background field will jump to that element.

3.
In the Entity Class Window (Figure 5), double-click on utilities_electrical_ext_light to view the full definition and the associated Entity Types (Features)
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Figure 5 - Entity Class Window

4. In the Entity Type Window (Figure 6), find the desired Entity Type in the Entity Type List.
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Figure 6 - Entity Type Window

The Window displays information about the Entity Type.

Browse By Feature Name – Find the Feature using its Name.  Note that each Feature has only a single name.
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Figure 7 - Browser by Feature

Next you will find the entity definition for an exterior light
1. From the <Browse> menu choose <By Feature>.

2. On the Feature List (Figure 7) find the Light, Exterior by either scrolling down the list of Features or filtering the list using the “L” button for Light, and then finding “Exterior”.

3. Double Click on Light, Exterior to display the Feature Screen (Figure 8), which contains details about the Feature including organization, Table Name, Definition, and Symbology Codes.
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Figure 8 - Feature Screen

Browse By Feature Alias – Find the Feature using an Alias.  Note that each Feature may have many aliases.
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Figure 9 - Browser by Feature

1. From the <Browse> menu choose <By Alias>.

2. On the Alias List (Figure 9) find the “LIGHT”.  Since “LIGHT” is an alias for more than one Feature, a list of potential features will be displayed.  See Figure 10). 
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Figure 10 - Features from Alias

3.
Double clicking on the desired feature will jump to the same Feature Screen (Figure 8).
Browse by Keyword

1. From the <Browse> menu choose <By Keyword>.

2. Enter “light” into the “Search For” field of the Keyword Search Window (Figure 11). Then click 

Begin Search’.

3. Double-click on the Entity Type Name – EXTERIOR LIGHT POINT in the keyword search results list to display the Entity Type Screen for the Feature.
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Figure 11 - Keyword and Results

Continue using the Browser to gather pertinent information for your project spreadsheet or Feature List.
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Figure 12 - Tables Screen

Moving from Feature to Table/Attribute – Each Feature/Entity Type in the SDSFIE/FMSFIE is linked to a data table, which contains the specific attributes which define the characteristics and properties of the Feature.  To get from a Feature or Entity Type to the table, use the “FILE/TABLE” tab on the screen.  To jump to the applicable table, double click on the Table Name (ususally of the format SSCCCTTT where SS corresponds to the Entity Set, CCC corresponds to the Entity Class, and TTT defines the specific table

This action will display the Table Screen (Figure 12).

The Table Screen displays information about the table, where it is used, and any relationships between tables.  In order to see the attributes in a particular table, double click on the table again in the list on the left side of the Table Screen.  This will jump to the Attribute Screen, shown at the top of the next page in Figure 13.
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Figure 13 - Attribute Screen

Figure 13 shows the Attribute Screen, which provides detailed information about the attributes in a particular table, including various formats for names, data types, domain values, definitions, and other pertinent characteristics of the attribute as it relates to the SDSFIE/FMSFIE.

These names, data types, and characteristics are considered when using the SDSFIE/FMSFIE toolbox to build and maintain a database.

Using the Filter Maker

The Filter Maker permits the development, definition, modification, implementation, and saving of a Filter, or subset of the entire SDSFIE Library.  A filter is used to limit the size of the data schema used in a SDSFIE/FMSFIE data implementation. Filters limit display and use of all aspects of the SDSFIE to include Entity Sets, Classes, and Types, as well as Tables, Attributes, and Domains.  A custom filter is a user-defined filter.  Although the creation of a custom filter is optional, it will greatly increase the efficiency of the SDSFIE/FMSFIE database generation process and is useful for nearly all of the tools in the SDSFIE/FMSFIE toolbox.

For the purpose of this guide, a filter named “LIGHTS” will be developed.  The steps outlined in the following section guide the user through the tasks necessary to create the filter.

Note:  SDSFIE/FMSFIE data does not support filter operations with pre-TSSDS/TSFMS 1.80 releases.
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Figure 14 - Filter Maker

To open the Filter Maker and create a filter

1. From the Windows Start Menu choose Filter Maker.

2. On the first panel of the Wizard, choose <Connect> to connect to the SDSFIE/FMSFIE Library.
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Figure 15 - The Connection Screen

3. On the Connection Screen (Figure 13) Verify and/or change the location of the data connection files and choose <Connect, Test and Save>.  Click <Next>.

4. Choose the “Create a New Filter” option, and then choose <Next>.

5. For the name of your filter enter “Exterior Light”, and then choose <Next>.
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Figure 16 - Naming a Filter

6. Continue through the Wizard until the Feature List is reached (See Figure 15).
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Figure 17 - List of Potential Features

7. Choose <Select Features Dialog>.  This button displays a Dialog which permits users to select Features based on the Structure of the SDSFIE/FMSFIE; e.g. by Entity Set, or Entity Class, or Entity Type, or based on a previous constructed filter or one of the “canned” filters in the SDSFIE/FMSFIE.  (See Figure 16)
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Figure 18 - Selecting Features

8. Choose “Features in selected Entity Class”, select “utilities_electrical_ext_light”, click <Add Class>, and click <Insert in Filter>.

9. From the Wizard, click <Next>.

10. At the Summary Screen (Figure 17), verify the Features, the Filter Name, and edit the Filter Definition as desired, click <Next>.
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Figure 19 - Summary Screen

11. When correct, click <Create>.

12. When the Filter has been entered into the SDSFIE/FMSFIE Library, the Filter Maker will display
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Figure 20 - Completion Screen

After 30 Seconds, the Dialog will automatically close and the Filter Maker will terminate.

Erasing a Filter

The Filter Eraser is used to restore the SDSFIE/FMSFIE Library to its original configuration.  It operates very similar to the Filter Maker (Wizard).  The following steps are to be used in erasing a user created custom filter (*Note: the SDSFIE/FMSFIE Filter Eraser is a separate program like the Filter Maker)

1. From the Windows Start Menu choose Filter Eraser.

2. Choose “Connect to SDSFIE/FMSFIE Library”.

3. Establish the connection in the same manner as the Filter Maker.  Click <Next>.

4. Choose the filter(s) you would like to erase, and then choose <Next>.
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Figure 21 - Filter Eraser Filter List

5. At the Verification Screen, choose <Erase>.

Using the Access Builder

New to release 2.00 of the SDSFIE/FMSFIE is the Access Builder. This tool automatically builds the SDSFIE structures (tables, attributes, and domains) in a Microsoft Access database. It replaces and expands the functionality of the SDSFIE/FMSFIE Generator Tool first introduced in Release 1.600 of the TSSDS. Version 2.0 of the Access Builder generates a Microsoft Access 97 database.  (Future releases of the Access Builder will support both Access 97 and Access 2000).  This tutorial will use the builder to create a database structure used to store field-captured data pertaining to the exterior lighting system.

To open and build a database

1. From the Windows Start Menu choose Access Builder.

2.    From the <Open> menu, choose <Library Connection> to connect to the SDSFIE/FMSFIE Library.

3.  On the Connection Screen. Verify and/or change the location of the data connection files and choose <Connect, Test and Save>.  Click <Next>.

4.  From the <Open> menu choose <Create Access Database>.

5.  For the database name enter “Exterior Light”, and then choose <OK>.

6. Choose “Tables in Selected Filter” and double-click “Exterior Light” to add all the features to the Candidates List.
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Figure 22 - Selecting the Filter

7.  Choose <Add to Candidate List>.

8.  From the <Action> menu choose <Add Candidates to Access> to display the Addition Option Dialog (Figure 21).
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Figure 23 - Addition Options

Note:  See the Application Help File for information on the available addition options.

9.  Choose <Build/Generate> to convert the candidates to Access Tables.

Populating the SDSFIE/FMSFIE database

The next step in the implementation process is populating the database.  You will notice that when “Exterior Lights.mdb” was created, it was an empty database.  To use the database you must populate it with the appropriate data.  Many techniques may be employed to populate the Access database, including “Import”, Forms, manual input, or another application.  The Access Interface offers a number of options for adding, modifying, and editing data.  (If you are using Microsoft Access 2.0, you must convert the “Exterior Lights.mdb” file (which is a Microsoft Access 97 file) before populating it with data.)

In this tutorial, we will populate the database by importing records from a text file that describes the features in the spatial data set. The Access Builder created all necessary tables and relationships among them.  An ASCII text file (lights.txt) has been provided as a supporting document of this report.  Note that the first record in the text file is a header that contains the appropriate SDSFIE/FMSFIE attribute names which coincide with the fields of descriptive information in the text file.  It is not necessary to include all the attributes from an SDSFIE/FMSFIE attribute table in the text file to be imported.   The following steps will populate the SDSFIE/FMSFIE – Access database.

1. Start Microsoft Access.  Open the database Exterior Light.mdb by selecting Open Database, from the File menu. If the <Convert/Open Database> window is displayed, choose <convert> and type in a new file name for the conversion.  Make the Tables Objects group active.
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2. Select Get External Data/Import from File menu.
a. Within the Import dialog, select Files of Type:  Text Files (*.txt;*.csv;*.tab;*.asc)
b. Browse to the file lights.txt, 

c. Click Import
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3. From the Import Text Wizard window, select these options to import the data.

a. Select Delimited–Characters such as comma or tab separate each field 

Click Next
b. Select Comma as the delimiter that separates your fields. Check First Row Contains Field Names, Text Qualifier {none} Click Next.
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c. Select the button to specify that the data are stored In an Existing Table, choose utexllit.

d. If the text file you are importing contains attributes that are not included in the SDSFIE/FMSFIE table utexllit, click the <Advanced> button.  Click in the ‘Skip’ box for each attribute that should not be imported to table utexllit.  Click ‘OK’.

e.  Click Finish. Click OK to the dialog confirming the data were imported successfully.\

4. Double click the icon for the table utexllit, from the Table objects group to open and view the data.
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5. No other actions within Microsoft Access are required to link to ArcView GIS 3.x. To close the Microsoft Access application, select Exit from the File menu.

Note:  The Release 2.000 Access Builder constructs Access databases that are compatible with Access 97.  If Access 2000 is required, it is necessary to use Access 2000 to perform the transformation.

The SDSFIE/FMSFIE ToolBox also contains a Data Creator application for Microsoft Access.

Using the Access Data Creator

To open the database and select a table

1. From the Windows Start Menu choose Access Data Creator.

2. From the <Database> menu choose <Open>, and then select the Access database.

3. A List of available tables will be displayed (See Figure 22).

4. Select a table and the Fields associated with that table will be displayed.
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Figure 24 - Table Selection

To add a record

1. From the <Record> menu choose <New>.

2. Enter data as appropriate. Choose <Save Record> when finished.

3. Repeat the process for all the data as required.

4. From the <Database> menu choose <Exit> to close the program.

Creating an ODBC Data Source
Open Database Connectivity (ODBC) provides a standard interface between an application (i.e., ArcView) and the database (i.e., MS Access).  In order to create an ODBC data source for MS Access, perform the following steps:

1. From ‘Start’ menu, select ‘Settings’, ‘Control Panel’.

2. Double-click the ‘ODBC’ icon.

3. If ‘MS Access Database’ is not listed under the ‘User DSN’ tab, then

a. click the ‘Add’ button, 

b. select “Microsoft Access Driver (*.mdb)”,

c. click the ‘Finish’ button,

d. type ‘MS Access Database’ as the Data Source Name

e. click ‘OK’ 

4. Press the ‘OK’ button.
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Figure 25 - Configuring an ODBC Database

To configure the SQL Generator

1. From the Windows Start Menu choose SQL Generator.
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Figure 26 - Generator Menu

2. From the <Configure> menu choose <Connect>.  See Figure 26.

3. Verify and/or change the location of the data connection files and choose <Connect, Test and Save>.

4.    From the <Configure> menu, choose <Options> See Figure 26.

5.    On the <Output> tab, type the following:


ASCII Output File Path:  C:\…\TSSDS\Generate


ASCII Output File Name:  LightsTable.SQL

       Click <Save Options>.

6.   From the <Configure> menu choose <Configuration>.

7.   Under GIS Application Configuration choose ArcView/ArcInfo.

8.   Under Database Configuration choose Oracle SQL.
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Figure 27 - Select ArcView
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Figure 28 - Database Selection

9.  Click <Ok>

To generate tables and attributes

1. From the Generate menu choose New, then Table and Attributes.
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Figure 29 - Generating Tables and Attributes

2. For the Generation Mode choose Custom Filter Schema, then double-click “Exterior Lights” custom filter.
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Figure 30 - Selecting Features

3. For “Generate to”, choose C:\…\TSSDS\Generate\LightsTable.SQL to save your code to the file you specified previously

4. Choose <Generate> then <Close>.
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Figure 31- Building Domain Values

To generate domains and values (See Figure 31)

1. From the <Generate> menu choose <New>, then <Domains and Values>.

2. For the Generation Mode choose <Prior Generation>.

3. For “Generate to”, double click on C:\…\TSSDS\Generate\LightsTable.SQL and change the filename to “LightsDomain.SQL”.

4. Choose <Locate Generation SQL>, choose the file “LightsTable.SQL” from the previous step, then choose <OK>.
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Figure 32 - Building Relationships
5. Choose <Generate>, then <Close>.

To generate join/table relationships

1. From the <Generate> menu choose <New>, then <Relationships/Joins>.

2. For the Generation Mode choose <Prior Generation>.

3. For “Generate to”, double click on  C:\…\TSSDS\Generate\LightsDomain.SQL and change the filename to “LightsJoin.SQL .

4. Choose <Locate Generation SQL>, choose the file “LightsTable.SQL”, and then choose <OK>.

5. Choose <Generate>, then <Close>.

Compiling SQL Code in Oracle

To create a user

Your Oracle DBA should assign a username and password for you. For this guide we will use the username USER with the password PASSWORD.

Using SQL+ Worksheet

Your Oracle DBA should use SQL+ Worksheet to load and compile the 3 SQL files created from the SQL Generator.

To populate the database

Your Oracle DBA should import the 2 text files into your newly created data structure.

NOTE:  The SQL Scripts generated can be run directly into the Oracle SQL Plus series provided your DBA has created the owner and database, and you have configured SQLNet and the ODBC Data Source.

The syntax for running these scripts in SQL Plus is:

@ C:\Program Files\TSSDS\Generate\LightsTable.SQL

Configuring an Oracle Database in ArcView

You may configure an external Oracle database for use with ArcView 3.2 by using Oracle Provider driver. This driver is loaded during the initial installation of ArcView. Unlike Access, the process for using Oracle as your data source is not as automatic. You will have to manually create a DSN and UDL file.

To set up an ODBC

1. From the Windows Start Menu choose Settings, then Control Panel.

2. Double-click on Data Sources (ODBC).

3. Under the System DSN tab choose Add.
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4. Choose Microsoft ODBC for Oracle from the driver list, and then choose <Finish>.

5. Enter a Data Source Name and the Server Name (get this from your Oracle DBA). For this tutorial we will use acadmap for the DSN and acadmap for the Server.
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6. Choose <OK> then <OK>

[image: image45.png]BC Data Source Administrator

UserDSN System DSN | File DSNI| Drivers | Tracing | Cannection Pasing | About|

System Date Sources

Narme Driver Add
Micrasoft ODEC for Oracle
ECDCMusic Microsoft Access Driver (“mdb) Bemaove

Corfigure.

indicated date provider. A System data source is visible to all users on this

An ODBC System date source stares information about howto connecto the:
machine, incluing NT services.

oK Cancel Apply Help





ArcView GIS Characteristics and Capabilities

ArcView 3.2a

ArcView geographic information system (GIS) software from Environmental Systems Research Institute (ESRI) is a complete system for accessing, displaying, querying, analyzing and publishing geographic data.

ArcView is capable of linking to Microsoft Access, dBASE, FoxBASE, ASCII, INFO or any SQL or ODBC (Open DataBase Connectivity) database to graphic features in a geospatial set.  ArcView supports virtually an unlimited number of dynamic linkages to non-homogenous DBMS formats that may reside on a local disk or on a heterogeneous network at another location.  Many layers can then be classified and symbols assigned based on data attribute values.  ArcView also provides extensive tabular data analysis tools to sort, query, and create statistical summaries, add new fields, calculate new information based on existing attribute fields, or interactively edit the contents of any field.

ArcView supports vector and raster formats including the ArcInfo and PC ArcInfo vector feature types (e.g., points, lines, and polygons) and ArcInfo’s advanced feature types (e.g., routes and regions, raster images and surface grids).  Geographic data sets, such as satellite images and aerial photographs, can be geo-referenced and displayed underneath vector themes for visual reference or as a background source for data entry.  ArcView supports ERDAS, BSQ, BIL, Sun raster files and run-length compressed raster files as well as both opaque and transparent image display.

For information on the most current version of ArcView and its capabilities please visit ESRI’s website at http://www.esri.com/software/arcview/index.html
Implementing the SDSFIE/FMSFIE Using ESRI ArcView GIS Version 3.2a

Software Requirements

Primary GIS Software Package

ArcView Version 3.x

Primary Relational Database Software Package

Microsoft Access 97/2000 

Operating System

Microsoft Windows NT version 4.0, Windows 2000/98/95

Database Drivers for Operating System Drivers

Microsoft Open Database Connectivity (ODBC) Desktop Database Drivers version 3.51 installed. These are necessary to allow ArcView to read information directly from a Microsoft Access database (*.mdb) 

Sample Data Sets

The data used for the SDSFIE/FMSFIE Implementation Report was developed by the CADD/GIS Technology Center for Facilities, Infrastructure and Environment in Vicksburg, MS. These datasets include an ASCII text file, lights.txt, and three shape files: lightspro.shp, (exterior light features, graphics only -see implementation scenario 3 below) bggen.shp (buildings general-buildings structure) and trveh.shp (transportation vehicle road segments). 

SDSFIE/FMSFIE Implementation Scenarios

Various applications of GIS require specific implementation strategies depending on the type data available, graphic, tabular, hardcopy or GIS ready to use digital spatial data sets.  Issues that require consideration prior to integration with GIS are: (1) knowledge of the data origin and/or development cycle; (2) graphic data may need to be digitized, and attributed manually to assign descriptive values; (3) graphic data that are digital without descriptive attributes; or (4) spatial organization or GIS ready data sets such as those available from the World Wide Web. To implement any of the above scenarios, a user must have a clear understanding of ArcView and the SDSFIE/FMSFIE.

ArcView Project Setup with the SDSFIE/FMSFIE

The applicable implementation task covered by this guide is for GIS ready data sets that are to be process for SDSFIE/FMSFIE compliance. The graphic data files are provided as ArcView shapefiles (*.shp), and additional attribute information is provided as a standalone ASCII text file.

The user should be advised that if it is necessary to edit a non-ESRI graphic data file in ArcView, (for example, making an update to the geometry or attributes), the data file must be converted to an ArcView shapefile. When a CAD file (MicroStation or AutoCAD) is opened in an ArcView environment, all features portrayed in the file are interpreted as lines, points, polygons, text, and/or annotation.  All graphic attributes associated with these features i.e. layer, level, color, line type, line width, and style are presented in an attribute table (either line, point, polygon, or annotation attribute) for the CADD file map data set.  It is advised that all editing of non-ESRI spatial data file take place in the “native” software environment i.e., MicroStation or AutoCAD.

A similar situation exists with database file. ArcView can utilize and analyze values from an existing RDBMS (Access, Oracle, SQLServer), however, the user cannot populate or edit the database tables directly using ArcView’s graphical user interface.  If it becomes necessary to edit the database file it is recommended this operation take place in the “native” environment, i.e., Oracle or Access.

Preparation of Attribute Data for Inclusion in an SDSFIE/FMSFIE Database

The work flow diagram below outlines the steps that are used to establish an ArcView working environment with the SDSFIE/FMSFIE.
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Relationship between ArcView Project setup and SDSFIE/FMSFIE implementation.

ArcView Implementation

After the SDSFIE database is created and populated, and the ODBC drivers configured, a connection to the database can be established within ArcView. Two ArcView shape files, trevh.shp, and bggen.shp, representing base map feature geometries (points, lines, polygons), are included with this report.

1. Press Start/Programs/ESRI/ArcView 3.2/ArcView 3.2 from the Windows Desktop.

2. In the ArcView Project window, select the Views icon, click New to create a new View.

3. Save the project file tutorial.apr for later reference.

4. Make the View window active and select the Add Theme from the View menu.

5. Browse to the location of the base map shape files, trevh.shp, and bggen.shp. Hold down the shift key and click once on each file name in the Add Theme dialog. Click OK to add both of the themes to the View window. To display the features, click inside the box,placing a check beside the name of each file in the View Table of Contents.

6. To make the Project window active, select tutorial.apr from the Window menu .

7. Select SQL Connect from the Project menu to display the SQL Connection dialog. From the Connection drop down list, select MS Access Database. Click the Connect button, and browse to select the Exterior Lights.mdb SDSFIE/FMSFIE database. Click OK.

8. Double click utexllit from the list of Tables in the SQL Connect dialog. Double click <All Columns> from the list of Columns. In the Output Table text entry box, type utexllit. Click the Query button. The table will be added to the ArcView project. Close the SQL Connect dialog by clicking on the close window X button the in the upper right hand corner of the window.
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9. Return to the View window containing base features data sets. Select Add Event Theme… from the View menu. Activate the X-Y button in the top left corner of the Add Event Theme dialog. Select utexllit from the Table selection drop down list. Select coord_x from the X field drop down list. Select coord_y from the Y field drop down list. Click OK.
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10. From the View, make Utexllit the active theme. Select Zoom to Selected from the View menu. This will zoom the window to the spatial extent of the streetlights theme. Make the point features visible by clicking the theme check box.

11. Select the Identify tool from the ArcView tool bar. Click on any of the point features of the Utexllit theme. This action will bring up the Identify Result dialog to confirm the point location and associated attributes from the Exterior Lights.mdb database.
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Alternative Implementation Scenario

1. Return to the View window containing base features data sets. Add the theme lightpro.shp to the current view. This data set included the graphic light features without all of the attributes from the SDSFMS/SDSFIE database table.

2. Make the Project window active and highlight the Tables icon. Double click on the utexllit table to open it. Click on the field named Datalink to make it active.

3. Return to the View window containing base features data sets. Click on the lightpro.shp theme to make it active. Select Table from the Theme menu to open the Attributes of Lightpro.shp table. Click on the MSLink field to make it active.

4. Select Join from the Table menu. The utexllit table will automatically close, and its fields will be appended to the Attributes of Lightpro.shp table. SDSFIE/FMSFIE attributes can now be viewed by using the Identify tool.

Naming Conventions

The next step in the SDSFIE/FMSFIE implementation for ArcView GIS 3.2a is using the proper naming conventions for data sets for the View document and the ArcView project file (*.apr).

1. Activate the View containing the base data and street light themes. Select Properties from the View menu. In the Name entry box, type exterior_lighting_point. Select Feet from the Map Units drop down list. Select Feet from the Distance Units drop down list.
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The final step is to save the project file under a new name. Select Save Project As… from the File menu. Save the file as utilities_electrical_ext_light.apr under a directory on your computer named Utilities.
3. The exercise is complete, at this time you can end your session by selecting Exit from the File menu. 

ArcView Symbology Implementation

The final step in the process is to implement SDSFIE compliant and color schemes for features in the dataset. To load the ArcView SDSFIE color set that is included with this report, follow the steps outlined below.

1. Choose Symbol Window from the Window menu. Click the palette manager, far right button on the window. Change the Type drop down option to Color. Click the Clear button to discard existing colors in the palette. These will be replaced by a full set of SDSFIE compliant colors. 
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2. Click Load. Browse to the directory where the file sdsfie.avp is stored. Select the file and click OK.
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3. The full set of SDSFIE compliant colors are now available to symbolize the datasets.
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